Aggiornamento della piattaforma di hosting Linux

Per hosting condiviso

Per garantire ai nostri clienti una piattaforma sicura e stabile per le loro applicazioni web in futuro, abbiamo iniziato ad aggiornare l'ambiente del sistema operativo della nostra piattaforma di hosting e il sistema operativo Linux dei server dedicati gestiti. Prevediamo di completare l'aggiornamento entro la fine di agosto 2023.

Con l'aggiornamento, beneficerai automaticamente di un uso ancora più efficiente delle risorse, di una maggiore sicurezza del sistema e dei più recenti protocolli di sicurezza.

Nota bene

Per motivi tecnici, non possiamo evitare di interrompere brevemente l'hosting. Il tuo spazio web e i tuoi siti web non saranno disponibili per circa 5 minuti durante l'aggiornamento.

Dato che il backup dei dati viene effettuato automaticamente, non si verificheranno perdite di dati.

Software di hosting aggiornato

Oltre al server web Apache, per così dire il cuore dell'hosting, l'aggiornamento per gli sviluppatori web porta nuove versioni dei linguaggi di scripting Perl, Python e Ruby. Anche le utility MySQL sono state aggiornate.

La seguente tabella mostra quale nuova versione sostituisce il software precedente:

Nota bene

L'aggiornamento del server non influisce sulla configurazione e la versione di PHP, o sui database MySQL. È quindi possibile continuare ad utilizzare le stesse versioni PHP già in uso. Le ultime versioni del sistema di gestione dei database (DBMS) rimangono MariaDB 10.6 e MySQL 8 fino a nuovo avviso.

Software Versione precedente Nuova versione
Kernel Linux da 4.4 in su (patch di sicurezza attuali) 5.4
Server Web Apache 2.4.38 Apache 2.4.56
Meccanismi di sicurezza TLS 1.2 TLS 1.2
DBMS 5.5, 5.7 (MySQL) 5.7, 8.0 (MySQL)
10.6 (MariaDB)
MySQL Utilities Versione 15.1 Distribuzione 10.3.22-MariaDB Versione 15.1 Distribuzione 10.5.15-MariaDB
OpenSSH 7.9p1 8.4p1
OpenSSL 1.1.1n 1.1.1n
LINGUAGGI DI SCRIPTING    
PHP Ogni versione + PHP Extended Support Ogni versione + PHP Extended Support
Perl 5.28.1 5.32.1
Python 2 2.7.16 deprecato
Python 3 3.7.3 3.9.2
Ruby 2.5.5 2.7.4
Git 2.20.1 2.30.2
Nota bene

Python 2 nella versione 2.7.16 non sarà più disponibile dopo l'aggiornamento. Controlla gli script e i siti web e, se possibile, passa a Python 3.

Se per qualsiasi motivo non è possibile eseguire l'aggiornamento, contatta l'Assistenza Clienti IONOS. Cercheremo di trovare insieme una soluzione.