CERCA.X: ecco cosa si può fare con CERCA.X

Excel ha una funzione relativamente nuova, CERCA.X, che è stata integrata per la prima volta come funzione beta nell’agosto 2019 ed è attualmente disponibile solo in Microsoft 365 (ultima versione: luglio 2021). Se appartenete a questo gruppo di utenti e lavorate regolarmente con grandi raccolte di dati in Excel, vi sarà molto utile avere familiarità con questa formula. Nelle nostre istruzioni spieghiamo, con l’aiuto di alcuni esempi, come semplificare decisamente la ricerca di dati con CERCA.X e quando viene usata in genere questa funzione.

Cos’è CERCA.X?

CERCA.X di Excel appartiene alla famiglia delle funzioni di ricerca e di riferimento. È una delle funzioni più utili del popolare foglio di calcolo di Microsoft. CERCA.X è il modo più semplice per cercare voci specifiche in un intervallo di celle. Le voci vengono restituite formattate in un intervallo di celle predefinito. Suona familiare? Anche CERCA.VERT funziona secondo questo principio. Con CERCA.X di Excel, più flessibile, tuttavia, è possibile cercare non solo una, ma più voci con la stessa operazione. È anche possibile cercare ivalori verticalmente e orizzontalmente.

Cosa significa in pratica? Immaginate di avere un database digitale di clienti in un file Excel e di cercare l’indirizzo e il numero di telefono di una certa persona. Con CERCA.X è ora possibile cercare le voci corrispondenti per nome e ottenere immediatamente le informazioni desiderate. Non importa se i valori che state cercando si trovano in una colonna, in una riga o in una tabella in un’altra pagina. Ciò significa, quindi, che CERCA.X sostituisce non solo la funzione CERCA.VERT, ma anche CERCA.ORIZZ.

Fatto

In inglese la funzione si chiama XLOOKUP e come per l’italiano CERCA.X il nome della funzione indica già per cosa può essere utilizzata.

CERCA.X: casi d’uso tipici per la funzione

Prima di spiegare la sintassi della funzione CERCA.X di Excel e il suo utilizzo con alcuni esempi, ecco una breve panoramica dei casi d’uso più comuni:

  • Ricerca di una singola voce
  • Ricerca di voci diverse voci in un’unica operazione
  • Ricerca su più righe
  • Ricerca di una corrispondenza esatta e delle voci immediatamente minori o maggiori
  • Utilizzo di caratteri jolly nel criterio di ricerca

CERCA.X in Excel: Qual è la sintassi?

Per lavorare in modo efficiente con CERCA.X, occorre prima familiarizzare con i singoli parametri. Ogni funzione di Excel ha una sintassi specifica che richiede parametri specifici. Anche le più piccole deviazioni possono portare a un risultato errato o a un messaggio di errore. La sintassi valida per CERCA.X è la seguente:

=CERCA.X(Valore; Matrice_ricerca; Matrice_restituita; [se_non_trovato]; [Modalità di confronto]; [Modalità_ricerca])

Il significato esatto dei singoli parametri è riassunto nella seguente tabella. Gli argomenti contrassegnati da un asterisco sono opzionali:

Valore

La voce che state cercando; può essere un elemento di testo, un numero o un carattere jolly.

Matrice_ricerca

L’intervallo o la matrice in cui Excel dovrebbe cercare le informazioni desiderate

Matrice_restituita

L’intervallo o la matrice in cui Excel deve restituire le informazioni desiderate

se_non_trovato *

Se Excel non riesce a trovare una corrispondenza valida, può essere restituito un testo o un valore fornito dall’utente. Altrimenti, il programma visualizza il messaggio “#N/D”.

Modalità di confronto *

Si può specificare un tipo di corrispondenza utilizzando la modalità di confronto.

Modalità_ricerca *

In questa modalità determinate dove la ricerca deve iniziare (“1” per il primo e “-1” per l’ultimo elemento) oppure potete avviare una ricerca binaria.

N.B.

Parallelamente alla nuova funzione CERCA.X è disponibile anche CONFRONTA.X, che sostituisce la comprovata funzione CONFRONTA di Excel con funzionalità di ricerca ampliate.

CERCA.X spiegato con alcuni esempi

Esempio 1: ricerca standard con un valore restituito

Per il nostro primo esempio, usiamo solo i tre argomenti obbligatori “valore”, “Matrice_ricerca” e “Matrice_restituita”. Nella nostra tabella Excel di esempio, il cui contenuto si trova nelle celle da B2 a D10, sono mappati vari paesi con i relativi prefissi. Con la funzione CERCA.X vogliamo scoprire qual è il prefisso telefonico dell’Ungheria. Il risultato deve essere visualizzato nel settore G2 (a questo scopo è sufficiente selezionare la cella). La formula richiesta è la seguente:

=CERCA.X(F2;B2:B10;D2:D10)

F2 è il valore, in questo caso “Ungheria”. La matrice di ricerca è rappresentata dalla colonna dei prefissi e si estende da B2 a B10. La matrice restituita è la colonna in cui dovrebbe essere visualizzato il valore restituito e nell’esempio corrisponde all’intervallo da D2 a D10. Non appena si preme il tasto di invio, viene visualizzato il prefisso telefonico che si sta cercando.

Consiglio

Non volete inserire a mano CERCA.X in Excel? Basta selezionare le voci “Formule” e “Inserisci funzione” nella barra dei menu e cercare CERCA.X nell’elenco. Selezionate l’opzione “Tutte” in “Selezionare una categoria” se all’inizio non ottenete nessun risultato.

Esempio 2: Ricerca standard con due valori restituiti

Nel prossimo esempio, Excel deve restituire non solo il prefisso ma anche il codice corrispondente al paese selezionato tramite CERCA.X. A tale scopo, è necessario estendere la matrice restituita in modo che Excel possa trovare entrambi i risultati:

=CERCA.X(F2;B2:B10;C2:D10)
Consiglio

Se ci sono corrispondenze esatte nella tabella, la funzione CERCA.X mostra solo una delle corrispondenze. Per evitare risultati errati, potete rimuovere i duplicati prima della ricerca usando l’opzione di eliminazione dei duplicati di Excel.

Esempio 3: ricerca con l’argomento opzionale se_non_trovato

La formula del nostro prossimo esempio contiene non solo i tre argomenti obbligatori, ma anche l’argomento opzionale se_non_trovato. Questa aggiunta permette di specificare quale testo deve essere scartato in caso di una mancata corrispondenza. Per l’esempio definiamo il testo: “Dato non valido” come testo di output e cerchiamo il paese “Portogallo”, che non fa parte del nostro set di dati Excel.

=CERCA.X(F2;B2:B10;C2:D10;"Specifica non valida")

Esempio 4: ricerca con tre argomenti opzionali

In questo esempio, oltre ai tre argomenti obbligatori, usiamo gli argomenti opzionali se_non_trovato, Modalità_confronto e Modalità_ricerca.

Nella tabella di esempio, lavoriamo con diverse aliquote fiscali e i limiti di reddito ad esse associati. Usando la formula CERCA.X appropriata, vogliamo vedere restituita in F2 l’aliquota fiscale corretta dopo aver inserito il reddito di un dipendente nella cella E2.

=CERCA.X(E2;C2:C7;B2:B7;0;1;1)

In questo caso per il parametro se_non_trovato abbiamo specificato il valore “0”. In caso di mancata corrispondenza, viene quindi visualizzato “0” invece di “#/ND”. Dato che non state cercando una corrispondenza esatta, per la modalità di confronto è impostato il valore “1”, il che significa che verrà visualizzato l’elemento successivo più grande. Anche la modalità di ricerca è impostata su “1”, cosicché Excel cercherà nella tabella dal primo all’ultimo elemento.

Esempio 5: funzione CERCA.X nidificata

Infine, usiamo una funzione Excel CERCA.X nidificata. Questo offre la possibilità di eseguire una ricerca di corrispondenze contemporaneamente sia in verticale che in orizzontale, che è poi la caratteristica che rende speciale la funzione CERCA.X. Nell’esempio cerchiamo il fatturato del venditore con l’ID “1002” nel mese di aprile. La formula è la seguente:

=CERCA.X(B2;B6:B11;CERCA.X(C2;C5:H5;C6:H11))
N.B.

Se non volete che la formula cambi quando la copiate, impostate semplicemente un riferimento assoluto alla cella mettendo un segno di dollaro ($) davanti alla specifica della colonna e alla specifica della riga.