Excel: come usare la funzione INDIRETTO

Nell’utilizzo quotidiano di Excel inseriamo spesso i riferimenti di celle nelle formule: invece di utilizzare i calcoli normali e inserire manualmente i valori nella formula, Excel richiama i valori della cella inserendone semplicemente il numero corrispondente, anche se si trova righe e colonne più avanti. In questo modo il foglio elettronico di Microsoft diventa dinamico.

Con la funzione INDIRETTO di Excel si può fare un ulteriore passo avanti: al posto di scrivere il riferimento della cella nella funzione, lo si può recuperare semplicemente da altre celle o ricavarlo da più inserimenti. Sembra complicato, ma è molto utile!

Registra subito un dominio .it in offerta speciale!

Registra ora il tuo dominio .it con un consulente personale incluso!

Semplice
Sicuro
Assistenza 24/7

A cosa serve la formula INDIRETTO di Excel?

Con INDIRETTO Excel offre la possibilità di restituire il riferimento di un’altra cella invece di inserirlo direttamente in una funzione. In questo modo gli utenti possono comporre i riferimenti di cella recuperando il primo componente da una cella e il secondo da un’altra. Nella cella con la funzione INDIRETTO viene mostrato il valore che si riferisce al riferimento creato.

Di per sé la funzione INDIRETTO viene usata raramente. Si può pensare di utilizzarla quando si crea un modulo dinamico nel quale il riferimento di cella deve essere modificato continuamente tramite l’inserimento in una cella. Spesso la funzione INDIRETTO viene utilizzata in combinazione con altre funzioni.

Con INDIRETTO è quindi possibile rappresentare un valore proveniente da un altro foglio di lavoro o teoricamente da un’altra cartella di lavoro. Tuttavia la creazione di un riferimento simile funziona solamente se anche l’altra cartella di lavoro è aperta; se invece il file a cui deve fare riferimento INDIRETTO è chiuso, compare un messaggio di errore al posto del valore.

Sintassi della funzione INDIRETTO

La funzione INDIRETTO è costituita da un argomento obbligatorio e uno facoltativo.

= INDIRETTO(Rif;[A1]) 
  • Rif: qui si inseriscono il/i riferimento/i di cella. Si può scrivere una parte del riferimento di cella anche direttamente nella funzione (tra virgolette). Il collegamento tra le due parti del riferimento avviene tramite il simbolo della e commerciale (&).
  • A1: l’argomento facoltativo indica la tipologia del riferimento di cella. Se l’argomento viene omesso o se si scrive VERO nella funzione, viene utilizzato il tipo A1. Se si utilizza FALSO la funzione viene interpretata come di tipo R1C1.

Excel utilizza nella maggior parte dei casi il tipo A1. Le righe vengono quindi numerate (A1, A2, A3…) e le colonne rappresentate con lettere progressive (A1, B1, C1…). Nelle impostazioni del programma si può anche impostare il formato R1C1 in cui vengono numerate sia le righe che le colonne. R5C10 indicherebbe quindi la cella in corrispondenza della quinta riga e la decima colonna.

Fatto

La scrittura di R1C1 deriva da Multiplan, il predecessore di Excel. Si può attivare ancora oggi questo tipo di scrittura nelle opzioni del programma alla scheda Formule.

Esempi per INDIRETTO in Excel

Se, ad esempio, B1 è nella cella A1 e in B1 si trova il valore 5, la formula seguente restituisce il valore 5.

= INDIRETTO(A1)

Excel riconosce l’inserimento di testo nella riga A1 come segnale per il riferimento di cella e lo interpreta di conseguenza.

La funzione diventa più complessa quando si suddivide il riferimento di cella.

= INDIRETTO("B" & A1)

In questo esempio si trova solo un numero nella cella A1. Basta quindi inserire la parte di riferimento che si riferisce alla colonna direttamente come lettera nella formula.

Sia le righe che le colonne si possono inserire in due diverse celle.

= INDIRETTO(A2 & A1)

È interessante utilizzare INDIRETTO anche quando si usa la formula per indicare valori presenti in altri fogli di lavoro. Ciò avviene ad esempio quando si prevedono tabelle e calcoli simili su più fogli di lavoro e si vogliono mostrare su un unico foglio dei valori scelti dagli altri fogli. Anche il nome del foglio di lavoro deriva da una cella.

= INDIRETTO("'"&A1&"'!C1")

Nella cella A1 si trova il nome del foglio di lavoro e in questo foglio il valore desiderato è nella cella C1. I segni aggiuntivi in questo tipo di funzione sono giustificati in quanto bisogna riportare il testo completo del riferimento (comprese virgolette e punti esclamativi). Dato che si tratta di un inserimento di testo all’interno di una funzione, per inserire le virgolette bisogna inserire una virgoletta semplice tra virgolette doppie. Segue poi il testo dalla cella A1 e alla fine un inserimento di testo più lungo: al nome del foglio seguono nuovamente delle virgolette, poi un punto esclamativo obbligatorio e infine la cella di cui si vuole selezionare il valore.

Quindi il valore nella cella A1 può essere sempre modificato, ad esempio con un menu a tendina oppure ordinando tra di loro i valori dei diversi fogli. In questo modo trascinando la formula (con il puntatore del mouse) Excel regola automaticamente i riferimenti alla nuova posizione della funzione.

Excel: INDIRETTO e le altre funzioni

La funzione INDIRETTO si utilizza spesso in combinazione con altre funzioni. Ha senso utilizzare INDIRETTO quando con la funzione SOMMA si vogliono sommare valori provenienti da altri fogli di lavoro. Quindi invece di predisporre la somma nello stesso foglio di lavoro come nell’esempio precedente e indicarla successivamente in un riepilogo, qui i valori si sommano direttamente nel riepilogo.

=SOMMA( INDIRETTO("'"&A3&"'!B1:B5"))

Con questa formula si sommano le celle da B1 fino a B5 nel foglio di lavoro indicato nella cella A3.

Inoltre con la funzione Somma è possibile addizionare valori provenienti da diversi fogli di lavoro.

=SOMMA(INDIRETTO("'"&A1&"'!C1");INDIRETTO("'"&A2&"'!C1");INDIRETTO("'"&A3&"'!C1"))

Questa tecnica si può estendere anche a molte altre funzioni matematiche o statistiche in Excel (ad esempio MEDIA).

Cloud Backup di IONOS

Evita costosi downtime! Facile soluzione di backup per il tuo business.

Semplice
Sicuro
Integrato