Se-allora: la funzione SE in Excel

Si tratta di una delle funzioni più utilizzate in Excel: SE. A volte si desidera eseguire qualcosa nel foglio di calcolo soltanto quando si raggiunge un certo stato. Ciò che è noto nella programmazione come IF query si può risolvere con una funzione se-allora su Excel. Il principio è lo stesso: se un valore è vero, allora si fa una cosa, altrimenti se ne fa un’altra. Vi spieghiamo come utilizzare correttamente la funzione se-allora e a che cosa serve.

Registra subito un dominio .it in offerta speciale!

Registra ora il tuo dominio .it con un consulente personale incluso!

Semplice
Sicuro
Assistenza 24/7

Che cos’è la funzione se-allora?

Con la funzione SE (questo è il nome corretto della funzione) potete effettuare un confronto logico: il valore richiesto è identico al valore atteso oppure no? Se lo è, allora segue un’azione. Se invece non lo è, l’azione viene sostituita da un’altra, cioè se A, allora B, se invece non A, allora C.

Ciò rende la funzione se-allora una delle più importanti di Excel. La funzione può essere utilizzata in tutte le situazioni possibili: sia che stiate lavorando con un semplice elenco di membri, con un foglio di calcolo con dati chiave aziendali o con rapporti statistici, troverete questa funzione di grande aiuto, sia da sola che in combinazione con altre.

Come funziona la funzione se-allora?

Ogni funzione in Excel si basa su una sintassi specifica e lo stesso vale per quella SE:

=SE(Verifica;allora_valore; altrimenti_valore)

La funzione contiene perciò tre parametri, di cui i primi due obbligatori.

  • Verifica: in questa posizione bisogna specificare la condizione, un confronto tra due valori, uno o entrambi sotto forma di riferimenti a celle. Le condizioni possibili possono essere:
    • Uguale a (=)
    • Diverso da (<>)
    • Minore di (<)
    • Maggiore di (>)
    • Minore o uguale a (<=)
    • Maggiore o uguale a (>=)
       
  • Allora_valore: in questo parametro si inserisce l’azione da compiere se la condizione è verificata. I risultati possono essere valori, stringhe, riferimenti di celle o altre funzioni. È necessario mettere tra virgolette le stringhe.
     
  • Altrimenti_valore: l’ultimo parametro è opzionale. Se non si specifica nulla in questa posizione, viene restituita la funzione FALSO. In caso contrario, la condizione altrimenti_valore si comporta in modo analogo a quella allora_valore.

Nella pratica, una funzione in Excel potrebbe assomigliare a questa:

=SE(A1>=100;"Obiettivo raggiunto";"Obiettivo non ancora raggiunto")

Consiglio

In Excel le funzioni devono sempre essere introdotte dal segno uguale e i parametri vanno inseriti tra parentesi. Se usate riferimenti alle celle, potete renderli assoluti con il segno del dollaro. Questo significa che le funzioni mantengono il proprio riferimento alla cella originale anche quando vengono copiate in altre celle.

Se lo desiderate, potete anche non inserire manualmente la funzione SE nella riga di inserimento: con “Inserisci funzione”, infatti, Excel vi offre la possibilità di aiutarvi a compilare correttamente le formule.

Se-allora chiarito con un esempio

La funzione SE viene utilizzata in un’ampia varietà di situazioni. La query logica può essere utilizzata, ad esempio, per ordinare dei dati di ordinazione. Nell’esempio seguente si prende in considerazione un inventario. Con SE (IF in inglese) è ora possibile creare un marker non appena un certo livello di stock è sceso al di sotto di un livello minimo prestabilito.

=SE(D2<10;"Sì";"No")

N.B.

Poiché non si imposta il riferimento alla cella nella funzione in modo assoluto, è possibile copiare la formula in altre righe trascinando la casella di riempimento. I riferimenti saranno regolati automaticamente.

Registrazione dominio

Più di un semplice nome.

Registra il tuo dominio con IONOS e approfitta di tutte le nostre funzionalità.

E-Mail
SSL Wildcard
Supporto 24/7

Oltre al riferimento di una cella, è anche possibile inserire altre funzioni in SE: ad esempio, è possibile assegnare uno sconto al prezzo originale se l’ultima vendita è stata effettuata troppo tempo prima.

SE((GIORNI(OGGI();F2))>30;C2*0,75;C2)

In questo caso la funzione GIORNI fa parte della verifica: la data corrente viene confrontata con la data specificata (in F2) e viene visualizzata la differenza nel numero di giorni. SE controlla se il numero è maggiore di 30. In questo caso, si verifica la condizione allora_valore e interviene il calcolo matematico che avete inserito: viene applicato uno sconto sul valore originale (nella casella F2). In caso contrario, viene mantenuto il valore originale.

Naturalmente è anche possibile includere le funzioni di Excel nei parametri per “allora” e “altrimenti”. Molto popolare è ad esempio l’annidamento della funzione se-allora in Excel. Lo svantaggio di SE è che la verifica conosce soltanto due risultati: VERO o FALSO. Tuttavia, se si vogliono distinguere diversi stati, può verificarsi di nuovo una funzione SE al posto di altrimenti_valore, la quale esegue un ulteriore controllo.

Nel nostro esempio sarebbe concepibile concedere uno sconto ancora maggiore ai prodotti che già offrono sconti se sono disponibili solo pochi pezzi. Questo ci dà due condizioni: che l’ultima vendita sia stata effettuata più di 30 giorni fa e che non ci siano più di 10 pezzi in magazzino. Pertanto dobbiamo includere una E nel parametro della verifica e un’altra domanda nell’altro parametro, perché vogliamo rendere possibili tre risultati: 50% di sconto, 25% di sconto e nessuno sconto.

=SE(E(GIORNI(OGGI();F2)>30;E2<10);C2*0,5;SE(GIORNI(OGGI();F2);C2*0,75;C2))

N.B.

Annidare la funzione SE è una soluzione molto pratica, ma ha i suoi limiti: teoricamente Excel può elaborare un se-allora 64 volte all’interno di una formula, ma non lo consigliamo. L’annidamento porta a una complessità che rende praticamente impossibile una sintassi priva di errori. Ad esempio può accadere di dimenticare una o più parentesi. Nelle formule, la risoluzione dei problemi richiede molto tempo. Pertanto è utile lavorare con colonne ausiliarie o altre funzioni come la funzione CERCA.VERT. Un’altra soluzione al problema dell’annidamento può essere la funzione PIÙ.SE.

Naturalmente è anche possibile inserire il se-allora in altre funzioni di Excel. Si può pensare ad esempio a una semplice funzione di SOMMA. Prendiamo il caso che un’azienda voglia sapere quanti articoli siano attualmente in sconto. In una tale situazione si può utilizzare la seguente formula:

=SOMMA(SE(D2=C2;0;1);SE(D3=C3;0;1);….)

Nella pratica quotidiana, però, si tratterebbe di una formula molto lunga. È più semplice lavorare con una colonna ausiliaria, nella quale utilizzate di nuovo la semplice funzione se-allora, inserendo quindi la funzione CONTA.SE. In questo modo è possibile contare solo le celle che soddisfano un determinato criterio, ad esempio contengono la parola “Sì”:

=CONTA.SE(E2:E11;"Sì")

PIÙ.SE: estensione di se-allora

A partire da Office 2016, Excel vi offre un’altra funzione. La funzione se-allora funziona in modo simile alla funzione SE: a seguito di un controllo logico viene assegnato un allora_valore, ma fino a 127 volte. La sintassi è quindi la seguente:

=PIÙ.SE(Qualcosa è vero1; Valore quando è vero1; [Qualcosa è vero2; Valore quando è vero2];…[Qualcosa è vero 127; Valore quando è vero127])

Ciò che si nota è che non c’è nessun altrimenti_valore. Ma questo significa anche che bisogna definire la conclusione nel caso opposto, nel nostro esempio nel caso in cui non vengano utilizzati sconti. Pertanto si applica:

=PIÙ.SE(E(GIORNI(OGGI();F2)>30;E2<10);C2*0,5;GIORNI(OGGI();F2)>30;C2*0,75;GIORNI(OGGI();F2)<=30;C2)

Le verifiche di entrambi gli sconti vengono effettuate una dopo l’altra. Infine segue il caso “altrimenti”: tutti i prodotti la cui ultima vendita risale a 30 giorni o meno.

Cloud Backup di IONOS

Evita costosi downtime! Facile soluzione di backup per il tuo business.

Semplice
Sicuro
Integrato

Abbiamo una proposta per te:
Web hosting a partire da 1 €/mese!

Dominio gratis
Certificato SSL Wildcard incluso
Assistenza clienti 24/7
A partire da 1 €/mese IVA escl. per un anno,
poi 8 €/ mese IVA escl.