Excel: come arrotondare correttamente

Il programma di fogli di calcolo di Microsoft, Excel, non solo permette di creare tabelle e diagrammi ben organizzati, ma alleggerisce anche il vostro lavoro. Funzioni e formule possono essere utilizzate per eseguire calcoli complicati, se si sa come utilizzarli. In quest’articolo vi spiegheremo come utilizzare correttamente la formula ARROTONDA di Excel.

Excel con Microsoft 365 e IONOS!

Incluso in tutti i pacchetti Microsoft 365: usa Excel per creare tabelle e organizzare i tuoi dati!

Office online
OneDrive con 1 TB
Supporto 24/7

Come funziona l’arrotondamento in Excel

Excel vi offre diverse funzioni per arrotondare. Iniziamo con la più semplice: la funzione ARROTONDA. Per applicarla è sufficiente inserire il numero che volete arrotondare. Il secondo argomento all’interno della formula ARROTONDA consiste nel numero che specifica a quante cifre Excel si vuole arrotondare il valore.

=ARROTONDA(Num;num_cifre)

L’argomento num si riferisce al valore che si vuole arrotondare; basta inserire un numero direttamente nella formula o specificare un riferimento ad un’altra cella.

Si usa il parametro “num_cifre” per specificare il numero di cifre a cui si vuole arrotondare l’argomento num. Le cifre decimali vanno specificate da valori positivi. Di conseguenza, il valore 0 non avrà alcuna posizione decimale e quindi genera un numero intero. Se si utilizzano valori negativi, le posizioni a sinistra della virgola sono arrotondate per eccesso o per difetto alla cifra decimale più vicina.

=ARROTONDA(22,5172;1) = 22,5
=ARROTONDA(22,5172;0) = 23
=ARROTONDA(22,5172;-1) = 20

Per eseguire gli arrotondamenti potete utilizzare “Inserisci funzione ()” o digitare direttamente la funzione nella barra della formula; in questo caso, ricordatevi di far precedere la funzione dal segno uguale (=), altrimenti Excel tratterà i vostri input come testo.

N.B.

Excel utilizza il cosiddetto arrotondamento commerciale per eseguire tale funzione: si arrotondano per difetto le cifre con i valori 1, 2, 3 e 4 e per eccesso i valori da 5 in su. Tuttavia, per definire personalmente come eseguire l’arrotondamento, è possibile utilizzare le funzioni ARROTONDA.PER.ECC e ARROTONA.PER.DIF.

Dato che Excel permette di nidificare le funzioni, non è necessario utilizzare una cella separata per arrotondare un valore. Quindi, potete combinare la funzione ARROTONDA direttamente con un’altra formula.

=ARROTONDA(MEDIA(17,251;3,4687;7,2513);2) = 9,32

Nell’esempio riportato, si crea il valore medio a partire da determinati numeri e si arrotonda il risultato. Nella cella apparirà solo il valore arrotondato.

ARROTONDA.MULTIPLO: la formula di arrotondamento più complessa

La funzione ARROTONDA.MULTIPLO restituisce un numero arrotondato al multiplo desiderato. Nella formula s’inserisce prima il valore da arrotondare, come con la normale funzione ARROTONDA. Anche in questo caso si può inserire direttamente il valore, fare riferimento a una cella o impostare la funzione nella barra della formula. Il secondo argomento è il multiplo a cui si desidera arrotondare il numero.

=ARROTONDA.MULTIPLO(Numero;Multiplo)

Ad esempio, se si desidera arrotondare a multipli di 25, è possibile utilizzare la funzione ARROTONDA.MULTIPLO. L’arrotondamento per eccesso o per difetto è determinato dalla distanza dal multiplo. Excel sceglierà sempre la distanza più breve. Una distanza identica in entrambi i sensi sarà arrotondata per eccesso.

=ARROTONDA.MULTIPLO(136;25) = 125
=ARROTONDA.MULTIPLO(142;25) = 150

Potete utilizzare la funzione ARROTONDA.MULTIPLO anche per arrotondare per eccesso o per difetto i minuti alle ore intere.

=ARROTONDA.MULTIPLO(A1;60)/60

Arrotondamento semplice: pari e dispari

È possibile arrotondare al numero intero pari o dispari successivo utilizzando due procedure di arrotondamento molto semplici, indipendentemente dal fatto che si desideri arrotondare il numero con o senza cifre decimali. Come argomento nella sintassi appare solo il numero da arrotondare.

=PARI(Numero)
=DISPARI(Numero)

I numeri positivi sono arrotondati per eccesso (3 diventa 4); i numeri negativi sono arrotondati per difetto (-1 diventa -2).

Modificare la visualizzazione: arrotondare solo superficialmente in Excel

Excel vi consente di formattare le celle per visualizzare solo un certo numero di cifre decimali. Cliccando con il tasto destro del mouse sulla voce di menu corrispondente, si apre un menu contestuale in cui è possibile selezionare “Formato celle...”. Nella scheda “Numeri” e nella categoria “Numero” è possibile inserire il numero di cifre decimali desiderato. Ad esempio, se si scrive 0 verranno visualizzati solo i numeri interi. La differenza rispetto alla funzione ARROTONDA è che l’arrotondamento tramite formattazione riguarda solo la visualizzazione. Vedrete il numero arrotondato sul vostro foglio di calcolo, ma il valore esatto, incluse le cifre decimali, rimane memorizzato in background.

Ciò si fa più evidente quando fate dei calcoli: se avete memorizzato i valori 2,4, 2,3 e 3,3 in celle formattate senza cifre decimali, vedrete solo 2, 2 e 3. Se però calcolate la somma di questi valori, Excel vi mostrerà come risultato 8, in quanto il programma considera anche le cifre decimali. Se utilizzate la funzione ARROTONDA il risultato sarà 7.

Excel con Microsoft 365 e IONOS!

Incluso in tutti i pacchetti Microsoft 365: usa Excel per creare tabelle e organizzare i tuoi dati!

Office online
OneDrive con 1 TB
Supporto 24/7