Excel: con la funzione INDICE estrarre i dati è facile

Una tabella Excel può assumere dimensioni significative nel tempo. Per non perdere però uno sguardo d’insieme, il programma offre molte funzioni utili, che non aiutano solamente nell’esecuzione di formule matematiche. Con funzioni come CERCA.VERT, INDIRETTO o CONFRONTA potete analizzare velocemente i dati. Excel offre inoltre la funzione INDICE, che permette di restituire il valore di una determinata cella. Ma quali sono i vantaggi?

Perché si utilizza l’INDICE in Excel?

In Excel si utilizza la funzione INDICE per riprodurre il contenuto di una cella definita dall’utente in un’altra cella. Per questo motivo la formula contiene quasi delle coordinate nei suoi argomenti. Sulla base dell’inserimento di colonne e righe, la funzione individua il valore desiderato in un’area anch’essa stabilita dall’utente. Tale valore può essere visualizzato direttamente in un’altra cella o trasmesso a un’altra funzione.

Visto che le informazioni vengono trasmesse tramite colonne e righe, la formula INDICE di Excel è adatta anche per lavorare con una matrice. Il programma così può estrarre il valore corrispondente dai due fattori inseriti.

Excel: sintassi INDICE

La funzione ha una sintassi molto chiara. Come parametro si inserisce l’area in cui effettuare l’analisi, poi le coordinate della cella ricercata.

=INDICE(matrice; riga; colonna)

I seguenti dati fanno parte della funzione:

  • matrice, che si definisce tramite la cella più in alto a sinistra e quella più in basso a destra
  • riga in cui si trova la cella ricercata
  • colonna in cui si trova la cella ricercata

L’intervallo viene sempre definito inserendo due celle separate tra loro da due punti. Se la matrice è costituita solo da una colonna o solo da una riga, è sufficiente un altro argomento. Excel sarà in grado di dedurre automaticamente se intendete la corrispondente riga o colonna.

Le coordinate vengono inserite direttamente come numero o si crea un riferimento di cella. Nelle celle indicate vengono nuovamente inseriti i numeri. L’inserimento è valido sempre in relazione all’intervallo selezionato e non a tutto il foglio di lavoro. Se la matrice inizia nella cella C2, la colonna D sarà la numero 2 e non la numero 4.

La funzione INDICE può anche essere ampliata: è possibile infatti inserire direttamente più intervalli di celle. Questa versione indicata come riferimento ha bisogno di un altro parametro:

=INDICE(riferimento; matrice; riga; colonna)

Il riferimento è formato da un insieme di intervalli. Questi vanno indicati tra parentesi tonde e separati da punto e virgola. Mentre i dati relativi a righe e colonne rimangono uguali, con questo ultimo parametro si stabilisce quale tra gli intervalli inclusi va utilizzato per la ricerca corrente.

A tal fine è decisiva la sequenza nel riferimento: l’intervallo inserito per primo è il numero uno. Si conta da sinistra a destra, indipendentemente da dove si trova l’intervallo nel foglio di lavoro. Se volete che il valore venga visualizzato in un’altra matrice, basta cambiare l’intervallo nell’ultimo argomento. Se il dato viene tralasciato, Excel presuppone automaticamente che venga inteso il primo intervallo.

Infine l’INDICE può essere utilizzato anche come formula di matrice. Qui un intervallo selezionato, che contiene più celle, viene restuito in un equivalente numero di celle. Una riga o una colonna possono essere visualizzati come segue: per prima cosa selezionate il relativo numero di celle vuote e inserite come al solito la funzione INDICE (la selezione non deve essere rimossa!). Invece di confermare l’inserimento con il tasto Invio utilizzate la combinazione di tasti [Ctrl] + [Shift] + [Invio]. L’intervallo selezionato compare nella posizione desiderata della tabella.

Esempi della funzione INDICE nella pratica

La versione più semplice della funzione INDICE consiste nella riproduzione del contenuto di una determinata cella. Per rendere più facile il lavoro con la formula utilizziamo i riferimenti di celle. Così è possibile indicare direttamente in una cella i dati relativi a colonne e righe e adattare in maniera dinamica una formula.

=INDICE(B2:E10;B12;B13)

Nelle celle B12 e B13 abbiamo inserito i dati relativi a righe e colonne. In questo caso è importante assicurarsi che l’intervallo della formula non includa i titoli esterni. Anche questa opzione sarebbe possibile, ma in tal caso i valori negli altri due parametri dovrebbero anch’essi essere adattati in modo corrispondente.

In caso di più tabelle con la stessa struttura la formula può essere adeguatamente ampliata. Supponiamo di avere quattro tabelle, una per ogni trimestre dell’anno. La struttura delle tabelle è però sempre la stessa: le colonne e le righe hanno la stessa struttura.

=INDICE((C4:F7;I4:L7;C11:F14;I11:L14);C16;C17;C18)

I dati per righe, colonne e intervallo ci vengono forniti dai riferimenti di celle. Per un inserimento semplice è possibile creare anche menu a discesa in cui selezionare poi i dati. Excel produce così con la funzione INDICE un utile modulo per la scelta del valore corretto.

La formula INDICE e altre funzioni di Excel

La formula INDICE funziona solo se conoscete i relativi numeri di colonne e righe. Se questi non sono numerati in modo chiaro ciò può essere un problema, soprattutto nel caso di tabelle più grandi. Si impiegherà più tempo a trovare i dati corretti che a cercare autonomamente il valore. Risulta più semplice se potete scegliere il titolo a margine del criterio e derivare la funzione dal numero di colonne e righe. Per farlo è necessario unire in Excel INDICE e CONFRONTA.

La funzione CONFRONTA cerca un valore o termine e indica che cella in una colonna o in una riga corrisponde al criterio di ricerca. Il vantaggio di questa combinazione: CONFRONTA può cercare un termine e riprodurre il risultato in INDICE, dove la funzione INDICE funge da criterio per colonne o righe.

=INDICE((C4:F7;I4:L7;C11:F14;I11:L14);CONFRONTA(C16;B4:B7;0);CONFRONTA(C17;C3:F3;0);C18)

Come si può notare entrambe le funzioni CONFRONTA si riferiscono solo alla prima matrice. Questo non è però un problema perché i titoli delle righe e delle colonne sono gli stessi in tutte le versioni della tabella.

In Excel la formula INDICE può essere ben abbinata anche con funzioni matematiche o statistiche come MEDIA. L’INDICE stabilisce (nuovamente assieme a CONFRONTA) l’intervallo per il quale va creata la media. Invece di indicarlo direttamente nella formula, è possibile modificare in modo dinamico l’intervallo da analizzare tramite la struttura della formula.

=MEDIA(INDICE(B2:E10;CONFRONTA(B12;A2:A10;0);0))

Ora basta adeguare il valore nella cella B12 e la media verrà calcolata in un’altra riga. Questa tecnica funziona molto bene per esempio anche in combinazione con la funzione SOMMA.